Page 1 of 1

JGE updates

Posted: Sun Oct 03, 2010 2:43 am
by MootPoint
Some minor fixes to JGE that allows it to compile correctly against pspsdk 0.9.6.

Re: JGE updates

Posted: Sun Oct 03, 2010 2:46 am
by MootPoint
Minor note: I also had to manually regenerate the libhgetools.a that's checked into SVN to link successfully against 0.9.6, ie 'make makefile.hge'.

Re: JGE updates

Posted: Wed Oct 06, 2010 9:18 am
by MootPoint
I've committed these changes to the SVN (including one other cast that I forgot to include in this patch). At this point, there's only two things you need to do to get it to compile on 0.9.6:

Go to GameApp.cpp, and make the following change (the psp calls in the latest sdk are now camelcase):

Code: Select all

void GameApp::Create()
{
   srand((unsigned int)time(0));  // initialize random
#if defined (WIN32)
  _CrtSetDbgFlag ( _CRTDBG_ALLOC_MEM_DF | _CRTDBG_LEAK_CHECK_DF );
#elif not defined (LINUX)
  pspFpuSetEnable(0);    // <----- THIS LINE NEEDS MODDING
#endif
And, as before, go to the JGE folder, and run 'make -f makefile.hge' to have it recompile the libhgetools.a library.