Page 1 of 1

Help Me.. My Vita Bricked...

Posted: Sun Nov 24, 2019 10:26 pm
by tunahanshn
Hello guys. I'm updated my Vita 3.73 today. But i heard Adrenaline is not working, and i'm decided to downgrade my firmware. I'm downloaded 3.68 firmware and used modoru fordowngrade. SCE Updater is runned but stucks at %11 and i'm faced C1-6548-3 error. Tried to reboot but not working. Now i'm stucked at recovery mode. I'm tried QCMA for unbrick but my PS Vita says "Latest firmware is aleady installed"

Please help me for this :/

Re: Help Me.. My Vita Bricked...

Posted: Mon Dec 02, 2019 10:00 pm
You'll probably have to wait until a new update is out so you can update from recovery mode. I don't really know about any other solution.

Re: Help Me.. My Vita Bricked...

Posted: Sun Dec 22, 2019 9:39 pm
by konit_oo
Sooner or later your vita will run out of battery. If you do not have any other ideas and are ready to take risky actions (brick your vita) here is my idea. Just try enter recovery mode of the system and if that is successful try to go back to restore the system. But please, have this as a last, last, last possible solution to try. Neither I know that in your case the vita will manage to boot in recovery mode, nether that restoring system will succeed. Maybe there is a possibility to brick your device, so please, let more opinions to be shared here. Maybe a better solution will pop up. Good luck :)